Skocz do zawartości
zombi

AstroHub 3 - pytania i odpowiedzi

Rekomendowane odpowiedzi

Uff, a myślałem, ze pytając się o rzeczy dla niektórych oczywiste, narażę się na śmieszność. Ale jak mawia ojciec Kazimierz: "wstyd nie cebula, w oczy nie gryzie".

Na silniku mam tylko "stepping motor 42BYG228B-01 2011.12.23" i patrząc np. tutaj: http://www.discotech.pl/produkty/silniki-krokowe/seria-42-mm.html widzę, że powinienem się zmieścić, pomimo że data przydatności do spożycia minęła  :)

Kwestia kabelków, w następnym kroku (do wtyczki od silnika wchodzi 6 przewodów, rozbiorę i porównam ze schematem AH, po czym nie omieszkam się skonsultować).

A stary laptok, który mi tyle krwi upuścił już się formatuje i stawia system

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Silnik ma nominalny pobór prądu 0,4A więc jest OK. Znalazłem w Sieci "kabelkologię" tego silnika i myślę, że trzeba będzie podłączyć:

Kabelki.jpg.76537851f8d2797730e43dc48d89

A1=Brązowy    pin 1 gniazdo DB9 w AH
A2=Żółty         pin 2 gniazdo DB9 w AH
B1=Czerwony  pin 3 gniazdo DB9 w AH
B2=Niebieski   pin 4 gniazdo DB9 w AH

Popatrz na rys. 8 w instrukcji oraz w tym wątku na post ID:41 i kolejne.

I jeszcze jedno: faktycznie masz a AH męskie gniazda DB9 ?  Jeśli dobrze rozumiem to chcesz wykorzystać ten sam silnik tak aby był naprzemiennie sterowany raz z  USBFocusera a raz z AH ? To trochę karkołomne zadanie, jeśli nie masz dokładnego schematu okablowania gniazda w USBFocuserze.

Pozdrawiam.

Marek

  • Like 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Coś pouciekały linki

Ja to sobie wyobrażam tak: zostawiam w USBfocuserze wtyk bez zmian (w razie czego mogę dalej wsadzić do skrzynki usb focusera). Na drodze silnik-AH wstawiam przedłużkę/łącznik gniazdo-gniazdo. Kwestia właśnie tylko połączenia odpowiednich pinów i właśnie do tego powoli dojrzewam.

Najgorsze, że zaczyna mi się podobać takie grzebanie w bebechach. Zawsze coś nowego. Specjalnie do astronomii kupiłem sobie ... miernik uniwersalny. Już nawet umiem zmierzyć napięcie :)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

O widzisz, to możesz miernikiem teraz podziałać i sprawdzić jakie są połączenia w oryginalnym silniku z USBfocusera. Przełącz miernik na zakres w którym mierzysz przewody - to wygląda najczęściej jakoś tak:

2015-01-13-Q2-Lovejoy.jpg.98d37303b013fd

i zmierz jakie piny z oryginalnej wtyczki są połączone z którymi kablami silnika. Jeśli masz połączenia kompatybilne z Robofocusem, to z silnika przewody biały i czarny są ze sobą zwarte i podpięte do pinu 5 wtyczki. A przewody brązowy, żółty, czerwony, niebieski są podpięte pod piny 1,2,3,4. Wtedy możesz tak samo podpiąć silnik do AstroHuba i pracować w trybie Unipolar (zakładka ustawień silnika). 

  • Like 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
7 minut temu, jolo napisał:

O widzisz, to możesz miernikiem teraz podziałać i sprawdzić jakie są połączenia w oryginalnym silniku z USBfocusera. Przełącz miernik na zakres w którym mierzysz przewody - to wygląda najczęściej jakoś tak:

2015-01-13-Q2-Lovejoy.jpg.98d37303b013fd

i zmierz jakie piny z oryginalnej wtyczki są połączone z którymi kablami silnika. Jeśli masz połączenia kompatybilne z Robofocusem, to z silnika przewody biały i czarny są ze sobą zwarte i podpięte do pinu 5 wtyczki. A przewody brązowy, żółty, czerwony, niebieski są podpięte pod piny 1,2,3,4. Wtedy możesz tak samo podpiąć silnik do AstroHuba i pracować w trybie Unipolar (zakładka ustawień silnika). 

Kurczak - nie mogę znaleźć od frontu fotki ale ma dokładnie tak w środku wtyczki:

Czujnik.thumb.jpg.6e6af7b270b7f070475bc1

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ja do wlutowywania układów scalonych z takich obwodów używałem znanej mi jeszcze z czasów szkolnych - bierzemy igłę taką do robienia zastrzyków o takiej średnicy żeby można było włożyć nóżkę układu scalonego piłujemy czubek igły tak, żeby koniec był równy, nakładamy igłę na nóżkę delikatnie ją obracając jednocześnie podgrzewamy lut lutownicą - upps teraz stacją lutowniczą :) Wystarczyło "trochę" poćwiczyć ot, kilka dni praktyk z lutownicą z rozlutowywaniem układów i budowaniem figur 3D z kawałka drutu :) Zresztą teraz są stacje lutownicze, hot air rozlutownice ....:)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Sferoida, weź pod uwagę, że USBFocus steruje silnikiem krokowym bardzo drobnymi mikrokrokami, a AstroHub tylko w półkroku. W związku z tym, jeśli Twój silnik jest podłączony pod oś wyciągu bezpośrednio, to na AstroHubie będziesz miał za małą precyzję ruchu. Mikrokroki w USBFocusie zwiększają rozdzielczość silnika tak, że połączenie bezpośrednie daje dobrą dokładność. Natomiast AstroHub powinien mieć przy silniku przekładnię (np mikrofocuser), żeby osiągnąć odpowiednią dokładność ruchu.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Coś pouciekały linki

Ja to sobie wyobrażam tak: zostawiam w USBfocuserze wtyk bez zmian (w razie czego mogę dalej wsadzić do skrzynki usb focusera). Na drodze silnik-AH wstawiam przedłużkę/łącznik gniazdo-gniazdo. Kwestia właśnie tylko połączenia odpowiednich pinów i właśnie do tego powoli dojrzewam.

Najgorsze, że zaczyna mi się podobać takie grzebanie w bebechach. Zawsze coś nowego. Specjalnie do astronomii kupiłem sobie ... miernik uniwersalny. Już nawet umiem zmierzyć napięcie :)

Zrób sobie oddzielny kabelek do AH i będzie git. Jak będziesz chciał używać USBFocus to będziesz używał kabelek od Korneliusza.

Wysłane z iPad za pomocą Tapatalk

  • Like 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Wracając do połączenia silnika. Sprawdziłem w USBFocuserze wtyczkę i mamy: piny 1-4 kabelki odpowiednio żłt. nieb. brąz czer., pin 5 ma wlutowane 2 przewody czarny+biały, piny 7 i 8 nie są wykorzystywane, piny 6 i 9 zmostkowane takim dżinksem (z postu Jacka chyba czujnik temperatury):

P1030410.thumb.JPG.8b997ca2d34d738970723 P1030412.thumb.JPG.aee0afcfa82ec9a14d94d

P1030411.thumb.JPG.3e9ca5502b4be0914ec89

P1030413.thumb.JPG.83b1534a1ae88be550ebb

Analizując instrukcję do AH i w/w posty powinienem połączyć w następujący sposób:

COMschemat.thumb.jpg.2a0bf931b2e61895127

Pinów 6-9 nie ruszam

Marek, trochę kolory mi się nie zgadzają z Twoją listą, ale chyba powinno być dobrze.

Mateusz, piszesz, że "na AstroHubie będziesz miał za małą precyzję ruchu. Mikrokroki w USBFocusie zwiększają rozdzielczość silnika tak, że połączenie bezpośrednie daje dobrą dokładność. Natomiast AstroHub powinien mieć przy silniku przekładnię (np mikrofocuser), żeby osiągnąć odpowiednią dokładność ruchu" . Raczej nie wchodzi w grę montowanie czegoś dodatkowego, prędzej wymiana silnika. Nie wiem jednak czy gra warta świeczki, czy nie jest to za duża apteka. Użytkując USBFocusera bezpośrednio i tak wprowadzałem wartości 5 jedn. obrotu lub 50-100 do zgrubnego ruchu. Kiedyś próbowałem zastosować 1 jedn. to trochę musiałem tych pojedynczych kroków naklikać, żeby cokolwiek się zmieniło. Jak już wszystko będzie hulać to sprawdzę i spróbuje zastosować wzór na CFZ z instrukcji AH

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Radek - masz silnik podłączony do pokrętła mikroruchów, czy do głównej ośki wyciągu?

Co do połączeń, to proponuję Ci kupić dwie męskie wtyczki DB9 z obudowami i połączyć je kabelkiem o odpowiedniej jakiej chcesz długości i wewnątrz jednej z nich zrobić odpowiednie połączenia. Wtedy jedną podłączysz do wtyczki silnika, a drugą do AH i powinno być dobrze. 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ja się nie chce wtrącać bo o elektronice to za bardzo zielonego pojęcia nimom ale:
Radek napisał - chyba że zmieniłeś zdanie, że chce korzystać z Korneliuszowego ustrojstwa. No to tak - tam jest silnik podłączany do sterownika, a sterownik oprócz zasilania 12V (na silnik i siebie - może robić za ręcznego pilota) ma gniazdo USB o przez to gniazdo jest sterowany swoim panelem ewentualnie słucha we wszelkich programach komend po ASCOMie. To czy nie lepiej tylko krótki kabelek USB A-B i wejście do Waszego ustrojstwa ????

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Wciśnij wtyczkę do końca, czasami ciężko wchodzi za pierwszym razem, a musi wejść do końca. Albo spróbuj na drugim gniazdku. I włączaj przy wyłączonym urządzeniu. Na pewno przed zapakowaniem działał.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
49 minut temu, jolo napisał:

Radek - masz silnik podłączony do pokrętła mikroruchów, czy do głównej ośki wyciągu?

Co do połączeń, to proponuję Ci kupić dwie męskie wtyczki DB9 z obudowami i połączyć je kabelkiem o odpowiedniej jakiej chcesz długości i wewnątrz jednej z nich zrobić odpowiednie połączenia. Wtedy jedną podłączysz do wtyczki silnika, a drugą do AH i powinno być dobrze. 

Silnik podłączony jest do osi mikroruchów. Może się źle wyraziłem, ale właśnie cały czas piszę o tym, że chcę sobie właśnie zrobić taką złączkę/przedłużkę typu gniazdo-gniazdo. Z jednej strony AH z drugiej USBfocuser, po środku właśnie taka złączka. Kwestia tylko połączenia pinów w tych dwóch gniazdach. A nie chcę rezygnować całkowicie z USBfocusera, bo gdy będzie jakaś awaria lub zechcę sprzedać to nie będę musiał na powrót nic przerabiać z silnikiem.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli masz do mikroruchów to nie ma najmniejszego problemu z precyzją ustawiania. A taką złączkę to myślę że tak jak napisałem będzie dobrze. Dwie takie wtyczki:

DB9-Male-Solder-Kit-1109SK-M-1.jpg

plus kawałek kabelka i gotowe. 

Jacek - nie do końca rozumiem jakby miało działać to co opisałeś :5640dc6f5718d_06Sad:

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
11 minut temu, jolo napisał:

Wciśnij wtyczkę do końca, czasami ciężko wchodzi za pierwszym razem, a musi wejść do końca. Albo spróbuj na drugim gniazdku. I włączaj przy wyłączonym urządzeniu. Na pewno przed zapakowaniem działał.

No niestety nic to nie daje :-(

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jak masz jakiś omomierz to sprawdź czy jest połączenie pomiędzy końcówkami wtyczki i pinami czujnika - obudowa wtyczki do brązowego, środek do białego, czubek wtyczki do zielonego. Potem możesz przełączyć na woltomierz DC zakres 20V i zmierzyć czy po podłączeniu jest na czujniku napięcie 5V pomiędzy zielonym i brązowym kabelkiem. Jak wszystko jest jak powinno, to by znaczyło że czujnik padł - odeślij mi go i naprawimy/wymienimy. 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
6 minut temu, jolo napisał:

Jacek - nie do końca rozumiem jakby miało działać to co opisałeś :5640dc6f5718d_06Sad:

Twój Wynalazek był by przelotką rozdziałką HUBową - tak przynajmniej zrozumiałem Radka ,,Chcę używać USBFocusera" - Było by najmniej komplikacji. Nic by nie przylutowywał.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
17 minut temu, jolo napisał:

Jak masz jakiś omomierz to sprawdź czy jest połączenie pomiędzy końcówkami wtyczki i pinami czujnika - obudowa wtyczki do brązowego, środek do białego, czubek wtyczki do zielonego. Potem możesz przełączyć na woltomierz DC zakres 20V i zmierzyć czy po podłączeniu jest na czujniku napięcie 5V pomiędzy zielonym i brązowym kabelkiem. Jak wszystko jest jak powinno, to by znaczyło że czujnik padł - odeślij mi go i naprawimy/wymienimy. 

Połączenia są, natomiast Voltomierz pokazuje mi -5V nawet jak zamienię - z + :-)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Hmhm, ale dalej nie rozumiem jakby to połączyć? Poza tym Radek chyba nie chce tego używać jednocześnie, to byłoby trochę bez sensu wg mnie...

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Dokładnie jest tak jak pisze Łukasz, nie będę korzystał jednocześnie z tych urządzeń. Kwestia wyszła bo nie mogę bezpośrednio połączyć silnika i AH.

Iluvatar, może i by było prościej, ale do teraz nawet nie wiedziałem, że cuś takiego jest. A dwie wtyczki + kabelek, to z tym powinienem sobie poradzić. Tylko trzeba skrzyżować ścieżki, bo jak bezpośrednio przyłożę wtyk USBfocusera do wtyku AH to pin 1 wypadnie w pinie 5 drugiego urządzenia. Chciałem się upewnić, czy przedstawione na moim schemacie połączenie jest właściwe.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
1 godzinę temu, sferoida napisał:

Iluvatar, może i by było prościej, ale do teraz nawet nie wiedziałem, że cuś takiego jest. A dwie wtyczki + kabelek, to z tym powinienem sobie poradzić. Tylko trzeba skrzyżować ścieżki, bo jak bezpośrednio przyłożę wtyk USBfocusera do wtyku AH to pin 1 wypadnie w pinie 5 drugiego urządzenia. Chciałem się upewnić, czy przedstawione na moim schemacie połączenie jest właściwe.

Upewnię się jeszcze jutro w robocie, jak nie zapomnę, ale na 99% właśnie w ten sposób działa gender changer, czyli wepniesz go sobie w AstroHuba i będziesz mógł o nim zapomnieć.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Radku, prośba do Ciebie: możesz sprawdzić jak jest podłączone gniazdo DB9 ( COM ) wewnątrz pudełka USBFocusera ? Chodzi mi o sprawdzenie czy jest wlutowane na sztywno do płytki czy też jest połączone z płytką kabelkami. Jeśli jest połączone kabelkami, to zrób proszę zdjęcie i wrzuć do wątku.

Chodzi mi głowie jeszcze taka myśl, że gdyby COM w USBFocuserze był na kabelkach to można by ewentualnie je przelutować, tak aby były zgodne z AH. Wtedy obyło by się bez dodatkowej przelotki ( redukcji ) i miałbyś jeden silnik, który mógłby być podłączany zamiennie do AH lub do USBFocusera. Zerknij też na http://www.mosaic-industries.com/embedded-systems/microcontroller-projects/stepper-motors/specifications . Nie jest to do końca dokładnie ten silnik który posiadasz ( inna końcówka ) ale z tej samej rodziny 228 i ma pokazaną rozpiskę kolorów na poszczególnych uzwojeniach ( ale zgodną z wcześniejszym schematem który przedstawiłem ):

uzwojenie 1: BRĄZOWY "+A" i ZÓŁTY "-A" z BIAŁYM odczepem na środku oraz

uzwojenie 2: CZERWONY "+B" i NIEBIESKI "-B" z CZARNYM odczepem na środku. Kropki oznaczają początek uzwojeń.

Pozdrawiam.

Marek

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

W obu urządzeniach, czy w jednym tylko? Na każdym wyjściu brak, czy na konkretnym?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

×

Powiadomienie o plikach cookie

Umieściliśmy pliki cookies w Twoim systemie by zwęszyć funkcjonalność strony. Możesz przeczytać i zmienić ustawienia ciasteczek , lub możesz kontynuować, jeśli uznajesz stan obecny za satysfakcjonujący.

© Robert Twarogal, forumastronomiczne.pl (2010-2018)