Skocz do zawartości
jolo

AstroEQ na CG4 (EQ3-2)

Rekomendowane odpowiedzi

Biorąc pod uwagę, że silnika DEC w ogóle nie miałem to rozdzielczość 0.29" / krok jest super :)

Podliczę sobie zaraz koszty i chyba się zainteresuje tym rozwiązaniem.

pytanie: co to znaczy "pulse guide" i czy można tą technikę wykorzystać mając kamerkę ASI120MC? moja wiedza z guidingu jest bardzo ograniczona. aktualnie używam dorobionego portu ST4 do fabrycznego kontrolera SW.

 

 

 

————————————————————————————————————————————————————————————————————————————————

Hybrid Stepper Motor| Stepper Motor Driver

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Tak, można z tą kamerką i modułem AstroEQ wykorzystywać pulse guide. To sposób guidingu, w którym informacje o korektach przekazywane są do sterownika montażu (EQASCOM w tym przypadku), zamiast przez kabelek ST4. Kabelek ST4 jest wtedy niepotrzebny - jeden kabel mniej :) 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Wlasnize skonczylem moje astroeq i nie wiem , czy nie dalem ciala , bo od razu podlaczylem silnik ( nie ustawilem pradu ) . Teraz jak bym nie probowal ustawiac sterownika , to na pinie ukladu 8825 mam caly czas 11.7v . Czy to oznacza , ze uwalilem sterownik ? Silniki to nema 17 , 1.7A , 3V 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Cześć,

mam problem z konfiguracją astroeq/eqmod

ustawiłem telepa w home_position w chwili kiedy chce wycelować np w saturna to teleskop ustawia mi sie "pupą" a nie tak jak powinno być. Co źle ustawiam?

 

Pzdr

Robert

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ustaw na Home montaż niech sobie dojedzie i jak się zatrzyma wtedy puść blokady montażu i ustaw go ręcznie na Polarną. Teraz już będzie dobrze celował.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

działa już prawie dobrze:), pojawił się kolejny problem. Kiedy ustawiłem się na marsa w stellarium, a później  chciałem zobaczyć saturna (a wiadomo iż saturn jest na prawo od niego) telep zaczął mi wędrować na E.

Czy macie pomysł dlaczego tak się dzieje ?

 

Pzdr

Robert

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

A na marsa dojechał prawidłowo? Możesz też mieć zamienione kierunki w którejś z osi. Trzeba zaptaszkować RA reverse lub DEC Reverse.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Pamiętaj że jeśli wybierzesz obiekt który znajduje się po przeciwnej stronie południa to teleskop robi "meridian flipa" z automatu... czyli de fakto jedzie w przeciwną stronę, ale tubę odwraca o 180*...

popróbuj te ruchy na sucho w domu. (trafienie w obiekt nie ma większego znaczenia - chodzi o to czy mniej więcej dobrze skieruje teleskop)

porównaj też ten ruch z "wskaźnikiem" teleskopu w stellarium. przy meridian flipie będzie wyraźnie widoczne ze wskaźnik porusza się "dookoła" a nie po linii prostej do obiektu.
 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Cześć,

Zielu masz rację, teleskop miał przekroczyć linie południka. Podczas prób telep poszedł ostro w dół aż musiałem go zatrzymać bo nogi statywu były już blisko:).

Czy istniej jakiś przełącznik w eqmod by nie robił meridianflip'a?

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
2 godziny temu, majcher napisał:

Cześć,

Zielu masz rację, teleskop miał przekroczyć linie południka. Podczas prób telep poszedł ostro w dół aż musiałem go zatrzymać bo nogi statywu były już blisko:).

Czy istniej jakiś przełącznik w eqmod by nie robił meridianflip'a?

A jaki to teleskop? Jeśli nie jest absurdalnie długi, to nie powinien przy flipie o nic zawadzać. To normalna procedura. Da się wymusić brak flipa, ale jest to upierdliwe, bo trzeka klikać za każdym razem. Jest przycisk w stylu: force flipped goto, na którymś z przełączalnych ekranów po lewej (tam co są współrzędne). On powoduje, że następne goto jest bez flipa. Ale trzeba klikać ciągle i w końcu i tak zapomnisz. A zasadniczo, to własnie robiąc dojazd do obiektu "ze złej strony" narażasz teleskop na kolizję.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Cześć,

czy takie ustawienia i wyliczenia w astroEQ dla EQ5 są optymalne i poprawne. Koła zębate - na silniku 16 zębów, na na Eq 40 zębów. (silniki Nema 17 Bipolar 0.9deg 36Ncm (51oz.in) 0.9A 5.4V)?

 

image.png.d87a49434d738b7848d16ebd9ae4a0d8.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
W dniu 25.08.2018 o 23:16, majcher napisał:

Koła zębate - na silniku 16 zębów, na na Eq 40 zębów. (silniki Nema 17 Bipolar 0.9deg 36Ncm (51oz.in) 0.9A 5.4V)?

Powinno być:

motor step angle: 0.9 (wynika z danych silnika)
motor gear ratio: 40/16 = 2.5
worm gear ratio: <ilość zębów na zębatce od ślimaka> = dla EQ5 jest to 144 dla RA i DEC
goto rate: <trzeba dobrać eksperymentalnie> = 400-800x
uStep gear changing: Enabled (zmienny mikro krok - dla wolnego poruszania powinno być 32usteps/step dla szybkiego 4usteps/step - wtedy może poruszać 
                                      się zdecydowanie szybciej w trybie Go-To.
Motor microstep level: zależy od sterownika silnika jaki mamy (w dokumentacji sterownika będzie)

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Po przeczytaniu tego tematu bardzo się nim zainteresowałem, powiem na wstępie że z dziedziny astronomii jestem jeszcze kompletnym laikiem a za to elektronikę kumam o wiele lepiej. 

Rozumiem, że ten projekt umożliwia sterowanie napędem paralaktycznym  w obu osiach oraz ustawianie się na wybrany obiekt tak jak ma to miejsce w fabrycznych systemach za około 1500 zł. Tu nasuwa się moje pytanie, jak wygląda takie sterowanie w terenie (czyt. w polu), czy potrzeba do sterowania podpiętego laptopa żeby wyszukać obiekt czy może sterowanie odbywa się z modułu Arduino ? 

Druga sprawa jakbym zamontował silniki (np. Nema 14) bez przekładni planetarnych i zastosowałbym przekładnie na kołach i pasku zębatym o podobnym przełożeniu (oczywiście jak wystarczy miejsca) to czy ma to szanse powodzenia ?

Temat trzeci to, jeżeli do sterowania potrzeba laptopa (niestety obawiam się, że tak) to chciałbym zbudować na bazie tego silnika sterowanie w jednej osi, po prostu jakbym nie chciał brać laptopa to podłączam do jednego silnika moduł np. Arduino Uno i steruje jednym silnikiem. Moje pytanie w tym temacie to z jaką prędkością trzeba kręcić ośką napędu żeby uzyskać prędkość gwiazdową ?

Na dzień dzisiejszy nie posiadam jeszcze żadnego napędu ale wiem, że ten co kupię będzie na pewno pasował :)) także chciałbym się przygotować żeby nie wydawać na darmo np. 270 zł na napęd w jednej osi.

Z góry dzięki za wszelkie wskazówki i pomoc, dodam że tej angielskiej strony nie czytałem bo jak chodziłem do szkoły to uczono mnie tego języka zza wschodniej granicy dlatego też mam pytania na, które pewnie znalazłbym odpowiedź na tamtej stronie.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Do sterowania AstroEQ potrzebny jest laptop, nie ma opcji sterowania z samego Arduino, albo np pilotem SynScan. 

Takie przełożenie jak opisałeś jak najbardziej się sprawdzi - kwestia tylko mechanicznego umocowania wszystkiego i obliczenia całkowitego przełożenia. Silniki muszą być bipolarne, bo sterowane są mikrokrokowo.

Sterowanie w jednej osi nie będzie problemem jak już będziesz miał napęd w jednej osi. Przy znanym przełożeniu i sterowaniu mikrokrokowym trzeba tylko będzie ustalić częstotliwość impulsów na wyjściu z Arduino, które podawane są na sterownik mikrokrokowy (A4988 czy DRV8825).

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Potwierdzając wszystko to co napisał Łukasz, dodam tylko mały szczegół w kwestii sterowania. Od wersji 8.00 jest możliwe dodanie prostego kontrolera ręcznego (RA+, RA-, DEC+, DEC-). Ułatwić to może czasem sterowanie montażem w obserwatorium, szczególnie kiedy chcemy precyzyjnie ustawić się na jakiś obiekt (obserwując przez szukacz). Szczegóły znajdziesz w tym wątku:

https://www.astroeq.co.uk/forum/index.php?topic=190.0

  • Like 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Będę coś myślał w tym temacie. Na początek pobrałem AstroEQ ale niestety pomimo aktualnej wersji jawy program cały czas monituje o instalację jawy, mój system to Win10 64bit, czy ktoś może miał podobny problem. Bez tego programu raczej marne szanse na jakikolwiek start. Zapytam też czy AstroEQ to jedyne narzędzie potrzebne do obsługi systemu GoTo czy może jest potrzebne jakieś inne oprogramowanie, chciałbym się dowiedzieć co potrzebuję żeby w pełni korzystać z zalet GoTo.

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
4 minuty temu, sylwas72 napisał:

Będę coś myślał w tym temacie. Na początek pobrałem AstroEQ ale niestety pomimo aktualnej wersji jawy program cały czas monituje o instalację jawy, mój system to Win10 64bit, czy ktoś może miał podobny problem. Bez tego programu raczej marne szanse na jakikolwiek start. Zapytam też czy AstroEQ to jedyne narzędzie potrzebne do obsługi systemu GoTo czy może jest potrzebne jakieś inne oprogramowanie, chciałbym się dowiedzieć co potrzebuję żeby w pełni korzystać z zalet GoTo.

Do obsługi GoTo będziesz jeszcze potrzebował ASCOM + EQMod:
http://eq-mod.sourceforge.net/eqaindex.html

To jest minimum, ale przydałby się jeszcze jakiś program typu planetarium, który pozwoli Ci na bezpośrednie i łatwe kierowanie montażu na obiekty:

https://www.ap-i.net/skychart/en/start

lub 

http://stellarium.org/pl/

i wiele innych.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
14 minut temu, sylwas72 napisał:

Będę coś myślał w tym temacie. Na początek pobrałem AstroEQ ale niestety pomimo aktualnej wersji jawy program cały czas monituje o instalację jawy, mój system to Win10 64bit, czy ktoś może miał podobny problem.

 

Nie miałem takiego problemu. Spróbuj po prostu pobrać ostatnią wersję Java pod Twoją wersję windowsa i zainstalować raz jeszcze https://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Z uruchomieniem AstroEQ problem rozwiązany, java w wersji offline mimo instalacji nie działała chyba tak jak powinna, po zainstalowaniu wersji online program ruszył. Będę powoli zbierał wszystkie części układanki i później na pewno będę miał jeszcze wiele pytań.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
8 minut temu, Jacek E. napisał:

Pamiętaj o platformie ASCOM, o której Jarek wspominał, bo nic nie ruszy.

Tak, tak już chyba wszystko mam ściągnięte, teraz część mechaniczno-elektroniczna, zakup teleskopu z montażem i się zaczną dopiero problemy :))

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Witam.

Doszła do mnie elektronika, czekam jeszcze na silnik. Dzisiaj chciałem załadować program do arduino i zobaczyć czy się uda, udać się udało i całą konfigurację przeszedłem. Jednak w momencie połączenia z EQMOD jest błąd połączenia, timeout, czy to normalne bez podłączonych silników (moim zdaniem chyba nie, chyba że mało wiem jeszcze ? ) czy jest to inny problem. Miałem wersję EQMOD 2.00 ale gdzieś wyczytałem, że źle działa i trzeba wrócić do 1.28, tak zrobiłem ale i tak się nie łączy, gdzie może leżeć problem ?

EQmod.png.0a1d38453b98c25591bc75ced3b1c1d9.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Taki efekt  w przypadku AstroEQ zdarza się dosyć często. To jest jego "pięta achillesowa". Właściwa sekwencja załączeń. Odłącz kabel USB i najpierw załącz zasilanie i dopiero po tym podłącz USB. Wtedy dopiero odpal EQMod. Jeżeli masz właściwie skonfigurowany port COM, to powinno pójść.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Mam pytanie do [mention=3584]AstroLutek[/mention], jaką szerokość paska zębatego zastosowałeś w swoim montażu ?
Pasek o szerokosci 10mm. Chciałem aby było możliwie sztywno. Zdało to egzamin.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
W dniu 31.10.2018 o 00:06, AstroLutek napisał:
W dniu 21.10.2018 o 16:34, sylwas72 napisał:
Mam pytanie do [mention=3584]AstroLutek[/mention], jaką szerokość paska zębatego zastosowałeś w swoim montażu ?

Pasek o szerokosci 10mm. Chciałem aby było możliwie sztywno. Zdało to egzamin.

Dzięki.

W dniu 30.10.2018 o 20:55, Esku1RES napisał:

Taki efekt  w przypadku AstroEQ zdarza się dosyć często. To jest jego "pięta achillesowa". Właściwa sekwencja załączeń. Odłącz kabel USB i najpierw załącz zasilanie i dopiero po tym podłącz USB. Wtedy dopiero odpal EQMod. Jeżeli masz właściwie skonfigurowany port COM, to powinno pójść.

Zainstalowałem wszystko od nowa i okazało się, że wszystko działa nawet na sterownikach 2.00 i Arduino podpięty tylko przez USB, dziwne ale ważne, że działa.

W dniu 19.10.2018 o 20:34, Esku1RES napisał:

... Od wersji 8.00 jest możliwe dodanie prostego kontrolera ręcznego (RA+, RA-, DEC+, DEC-). Ułatwić to może czasem sterowanie montażem w obserwatorium, szczególnie kiedy chcemy precyzyjnie ustawić się na jakiś obiekt (obserwując przez szukacz). Szczegóły znajdziesz w tym wątku:

https://www.astroeq.co.uk/forum/index.php?topic=190.0

Czy jest to możliwe również na Arduino bo wydaje mi się, że dotyczy to płytki na bazie Atmegi 162 ?

Wszystkie elementy doszły i przeprowadziłem pierwsze testy, udało się ruszyć silnikami ale obsługi tego wszystkiego to się będę długo uczył ?

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
23 minuty temu, sylwas72 napisał:

Czy jest to możliwe również na Arduino bo wydaje mi się, że dotyczy to płytki na bazie Atmegi 162 ?

Na Arduino nigdy nie działałem w AstroEQ, ale skoro to rozwiązanie również obsługuje port ST-4, to kontroler ręczny też powinien tu chyba działać (kwestia jest tylko wersji oprogramowania >= 8.00). Poprzez zwieranie do masy (pin 2) pinów 3, 4, 5, 6 wybieramy kierunek, a pinem 1 zwieranym (lub nie) bezpośrednio lub przez rezystor ustalamy prędkość. Łatwo to sprawdzisz przez podłączenie kilku switchy. Sam jestem ciekaw.

Gratuluję uruchomienia układu.

astroeq.png.c5a168dd40d00303a83c13a1c4e58d3d.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

×

Powiadomienie o plikach cookie

Umieściliśmy pliki cookies w Twoim systemie by zwęszyć funkcjonalność strony. Możesz przeczytać i zmienić ustawienia ciasteczek , lub możesz kontynuować, jeśli uznajesz stan obecny za satysfakcjonujący.

© Robert Twarogal, forumastronomiczne.pl (2010-2018)